Configurar apt-get en Nova Ligero 5.0 detras de un proxy

Saludos lectores, hace mucho que no escribo nada en el sitio y bueno ahi vaeso. Bueno les cuento primero que cuando nos encontramos detras de un servidor proxy, puede volverse complicado el uso del apt-get u sus variantes. Esto al menos con Nova 5.0 me ha sido fácil , mirandolo por un lado, pero resulta que tiene en el linux cubano un detalle que no me permite realizar ninguna instalaci´n, ni actualización.
Me explico
Ahi va forma humana como configuré para los mi proxy en la Universidad de Las Tunas.

1. Editaremos el siguiente archivo /etc/bash.bashrc como root

2. Pondremos las siguientes lineas al final de este archivo:

export HTTP_PROXY=http://username:password@proxyserver.net:port/
export FTP_PROXY=http://username:password@proxyserver.net:port/

3. Luego creamos el archivo proxy dentro de /etc/apt/apt.conf.d/

sudo nano /etc/apt/apt.conf.d/proxy
sudo gedit /etc/apt/apt.conf.d/proxy

Y agregamos las siguientes lineas:

Acquire::http::Proxy “http://usuario:password@direccion_del_proxy:puerto”;
Acquire::ftp::Proxy “ftp://usuario:password@direccion_del_proxy:puerto”;

/- Quedo así /-
Acquire::http::Proxy “http://arrechea:avc123xxx@10.x.x.x:31xx”;
Acquire::ftp::Proxy “ftp://arrechea:avc123xxx@10.x.x.x:31xx”;

Con esto, ya deberia funcionar nuestro apt-get detras de un servidor proxy.

Hata ahi todo como debe ser y como según algunas literaturas para debian e Ubuntu dicen…

PD: LUEGO DE ESTA TAREA EL NOVA 5.0 LIGERO CUANDO LO MANDO ACTUALIZAR ENTRA APARENTEMENTE A LOS SITIOS DE LOS REPOS EN LA UCI, PERO EL LIO ESTA CUANDO MANDO A UPGRADE, E INSTALL. ME DA UN ERROR. POR CIERTO MI UNIVERSIDAD USA EL (squid/3.4.8).

3 comentarios en “Configurar apt-get en Nova Ligero 5.0 detras de un proxy”

  1. Saludos, Baphomet, esta si que me deja de piedra dos arroba, a quien se le ocurrio la grandiosa idea…dejando el chucho, pero el usuario de proxy de ustedes es el correo de la empresa completo, que raro. pero sucede, mi consejo es que preguntes a tu admin de sistema de la empresa, porque el admin suyo debe de solo poner en el proxy el nombre de usuaro sin llegar al arroba. Asi que prueba solo sin arroba Acquire::http::Proxy “http://usuario:password@proxy.empresa:3128”;

  2. Amigo Arrechea, en mi caso mi usuario tiene la forma:
    usuario@empresa
    Por lo que quedaría:
    Acquire::http::Proxy “http://usuario@empresa:password@proxy.empresa:3128”;
    Si te fijas bien, TENEMOS DOS ARROBAS!!! Cómo se arregla esto!?

    1. Saludos, Baphomet, esta si que me deja de piedra dos arroba, a quien se le ocurrio la grandiosa idea…dejando el chucho, pero el usuario de proxy de ustedes es el correo de la empresa completo, que raro. pero sucede, mi consejo es que preguntes a tu admin de sistema de la empresa, porque el admin suyo debe de solo poner en el proxy el nombre de usuaro sin llegar al arroba. Asi que prueba solo sin arroba Acquire::http::Proxy “http://usuario:password@proxy.empresa:3128”;

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *